Skip to main content
Tools Created Edited

Text Editor

Function

  • MIDAS Text Editor is similar to a common text editor, which supports the basic editing functions of text documents such as "create", "save" and "print" in Windows environment (can be used in lieu of Windows notepad). Furthermore, it is also a document editor, which can open and easily edit all types of text files related to MIDAS Family Program.

 

Call

From main menu, select [Tool] tab > [Editor] group > Text_Editor.png [Text Editor]

 

Input

Create document

New : Create a new document.

Open : Open a Text document.

Close : Close a Text document.


Save document

Save : Save the document in use under the current filename.

Save As : Save the document in use under a new filename.


Edit document

Select characters

Word : Double click the relevant word.

Character line : Move the mouse cursor to the left gray margin and click.

Several lines : Move the mouse cursor to the left gray margin and drag the mouse downward.

Entire document : Press [Ctrl]+A.

Select vertically : Hold down [Alt] and drag the mouse to select the desired part in a rectangle.

Copy, cut, paste, delete

Copy

Select a specific range of the document and save it in the clipboard. Select the part to be copied and press [Ctrl]+C or select "Copy" from the Edit menu.

Cut

Select a specific range of the document and press [Ctrl]+X or select "Cut" from the Edit menu.

Paste

Paste the contents saved in the clipboard with Copy or Cut in the document. Move the mouse cursor to the insert position and press [Ctrl]+V or select "Paste" from the Edit menu.

Delete

Select the part to be removed and press [Delete].

Find and Replace

Find a specific string of characters (target string) in the document and replace the target string with a new string of characters. Assign optionally [Whole Word basis] or [Lower/upper case and Regular expression].

Find

Pressing [Ctrl]+F or selecting "Find" from the Edit menu will display the Find dialog box. Enter the string you want to search for, then press [F3] or click on the Next button.

Replace

Press [Ctrl]+H or select "Replace" from the Edit menu to display the Replace Dialog Box.

 

Move

Movement within the document can be easily accomplished using the following shortcut keys:
These commands coincide with other commonly used text editors for Windows.

 

Command

Shortcut Key

Content

Page Up

  PgUp

Move to the previous page

Page Down

  PgDn

Move to the next page

Home

  Ctrl + Home

Move to the head of the document

End

  Ctrl + End

Move to the end of the document

Previous word

  Ctrl + ←

Move to the previous word

Next word

  Ctrl + →

Move to the next word

 

Bookmark

Place a bookmark at a particular line of the document and use "Find Bookmark" to easily find the position in the document.

Setup Bookmark

After moving the cursor to the desired line, pressing [Ctrl]+F2 will indicate that a bookmark has been set with a blue highlight in the left gray margin.

Find Bookmark

Pressing [Ctrl]+F2 or [F2] will navigate to the next bookmarked section.

Remove Bookmark

Pressing [Ctrl]+F2 again on a bookmarked line will remove the bookmark for that line, and pressing [Ctrl]+Shift+F2 will remove all bookmarks that have been set.

Undo and Redo

Undo

Select "Undo" from the Edit menu or press the shortcut key [Ctrl]+Z or [Alt]+Backspace to revert the most recent change.

Redo

Select "Redo" from the Edit menu or press the shortcut key [Ctrl]+Y or [Shift]+[Ctrl]+Z to redo the previously undone change.

Page Feeder

Click the icon to insert a page feeder () to signify demarcation for separate pages for printing. The page feeder symbol () appears only in the edit state. New pages are actually generated in the preview or at the time of printing.

Document Printing

Header & Footer Setup

Click the icon or select the File → Header & Footer Set up menu to display the Header & Footer Setting Dialog Box. Statements may be added to the document as header and footer.

Printer Setup

Setup the printer, document type and direction.

Print Preview

Preview the text file before printing.

Two pages can be concurrently previewed and the size of the page displayed on the screen can be magnified or reduced.

Print

Print the current document.

Other Functions

Split Screen

A document created while is pressed has split screen scroll boxes. Small scroll boxes appear at the top of the vertical scroll bar and to the left of the horizontal scroll bar. By moving these boxes, the screen becomes split into two or four parts.

Select Font and Color

Select the View > Configure menu or click to display the Select Font and Color Dialog Box. The font and color may be changed in the Dialog Box.

View Blank and Tab

Click this tab to view hidden blanks [`] and tabs [^].

0
Was this article helpful?