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Enhancements

Enhancements in CIVIL NX 2025 (v2.2)

1. Steel-Composite Girder Design & Assessment Enhancements

2. Virtual Beam Display for Plate and Mixed Models

3. Virtual Beam + Span Information: Faster LTB checks on plate or mixed models

4. Virtual Beam Selection & Management

5. Virtual Beam Reinforcement Input

6. Virtual Beam Transverse Stiffener Input 

7. Virtual Beam Design & Assessment for Steel-Composite Girders

8. Virtual Section for Design

9. Bearing Stiffener Check (NR/GN/CIV/025) for Steel Railway Bridges

10. Intermediate Stiffener Check (NR/GN/CIV/025) for Steel Railway Bridges

11. Local Coordinate Displacement Output under Moving Load Cases
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1. Steel-Composite Girder Design & Assessment Enhancements

• Until the previous version, Steel-Composite Girder Design was supported only when the girders were modeled as Beam Elements. With this release, the design
workflow has been significantly extended:

• Full Plate Modeling Support: Entire steel-composite girders modeled with Plate Elements can now be directly designed.
• Mixed Modeling Support: Structures modeled with a combination of Beam Elements and Plate Elements are also supported, allowing more flexible modeling

strategies.

• Supported Codes
• Design: AASHTO LRFD (Load and Resistance Factor Design), Assessment: CS 454 (Assessment of Highway Structures)

• Key Benefits
• Engineers can now freely choose between beam-only, plate-only, or hybrid modeling approaches depending on project requirements.
• Plate-element-based modeling better captures local effects and distribution of stresses in steel-composite girders.

• Limitation
• Design and Assessment are supported only for Virtual Beams generated via the Steel Composite Bridge Wizard.

Steel-Composite Girder Bridge — Virtual Beam DisplaySteel Composite Bridge Wizard

▪ Structure > Steel Bridge > Steel Composite Bridge
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2. Virtual Beam Display for Plate and Mixed Models

▪ View > Display

• A new Virtual Beam Display option has been added to support the design of steel-composite girders modeled with Plate Elements or a combination of Plate and

Beam Elements.

• Display Settings
• In the Display > Element tab, users can enable Virtual Beam.
• In the Display > Property tab, users can enable Virtual Beam Section.
• Once activated, the model view will display the virtual beam representation.

• What is a Virtual Beam?

A Virtual Beam is not a physically modeled element. Instead, it is a design-oriented beam representation automatically generated from plate elements (or plate
+ beam elements). This allows users to conduct design checks as if the structure were modeled with traditional beam elements, while still benefiting from the
accuracy of plate modeling.

• Benefits for Users
• Clear Visualization: View beam-like design references even in complex plate or mixed models.
• Seamless Design Integration: Perform design checks on virtual beams without remeshing or remodelling.
• Time Savings: Avoid manual re-modeling by directly using virtual beams derived from your analysis model.

Virtual Beam

Virtual Beam Section
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▪ Structure > Steel Bridge > Composite Option > Span Information

3. Virtual Beam + Span Information: Faster LTB checks on plate or mixed models

• You can now define Virtual Beams per girder and perform lateral-torsional buckling (LTB) checks even when the steel-composite girder is modeled entirely with
plates or with a plate + beam (mixed) model.

• How it works

Create Virtual Beams by Girder

Open Span Information and set Element Type → Virtual Beam.

Select the plate/beam elements that belong to each girder to generate its Virtual Beam.

Tell the program where the girder is braced

In Span Information, set Support at each cross-frame (or diaphragm) location.

CIVIL NX then automatically determines the unbraced length between supports.

Automatic critical moment search

During the LTB verification, the program searches the maximum bending moment within each unbraced 

segment and uses that value for the check—no manual segmenting or re-meshing required.

Lateral Restraint

Span Information



6

CIVIL NX 2025 (v2.2)  Release NoteCIVIL NX 2025

4. Virtual Beam Selection & Management

• Selection
Supported selection icons: Select Single /Select by Window/Select All/Unselect by Window/Unselect All
When Virtual Beams are displayed, only Virtual Beams can be selected. This ensures a clear and convenient workflow, preventing accidental selection of
structural elements.

• Activation :
Activating or deactivating specific Virtual Beams only is not supported.
Virtual Beams are always kept in a fully active state when displayed.

• Deletion of Virtual Beams

Virtual Beams can be deleted in two ways:

1. Properties → Section Properties → Section for Resultant Forces → delete the corresponding Virtual Beam.

2. If the elements assigned to a Virtual Beam are deleted, the Virtual Beam is automatically removed.

• Zoom Functions

When all structural elements are deactivated and only Virtual Beams remain active, Zoom All and Zoom Fit do not operate.

These functions always work relative to activated elements only.

Virtual Beam Mode Element Mode

▪ View > Select > Select Single
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5. Virtual Beam Reinforcement Input

• You can now directly assign reinforcement to Virtual Beams through the familiar Longitudinal Rebar dialog.

• In the Longitudinal Rebar dialog, select “Virtual Beam” mode.

• Choose the Virtual Beam number from the list (Virtual Beam IDs can be confirmed in Model View).

• Reinforcement is then defined in the same manner as for standard Beam Elements, ensuring a consistent workflow.

• For multiple Virtual Beams with the same reinforcement pattern, the Copy Reinforcement function enables quick and easy input.

• Design-only usage: Reinforcement assigned to Virtual Beams is used only for design and assessment purposes.

• No impact on analysis: The reinforcement data is not reflected in the structural analysis results.

Longitudinal Rebar Dialog

▪ Design > Composite Design > Design Input Data > Longitudinal Rebar
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6. Virtual Beam Transverse Stiffener Input

• You can now directly assign transverse stiffener to Virtual Beams through the familiar Transverse Stiffener dialog.

• In the Transverse Stiffener dialog, select “Virtual Beam” mode.

• Choose the Virtual Beam number from the list (Virtual Beam IDs can be confirmed in Model View).

• Transverse stiffener is then defined in the same manner as for standard Beam Elements, ensuring a consistent workflow.

• For multiple Virtual Beams with the same stiffener pattern, the Copy Transverse Stiffener function enables quick and easy input.

Transverse Stiffener Dialog

▪ Design > Composite Design > Design Input Data > Design Parameters > Transverse Stiffener
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7. Virtual Beam Design & Assessment for Steel-Composite Girders

• CIVIL NX now supports the design and assessment of steel-composite girders modeled as Virtual Beams, extending the workflow beyond conventional beam
elements.

• Design: Perform Virtual Beam design according to AASHTO LRFD.

• Assessment: Carry out Virtual Beam assessment following CS 454 provisions.

• Virtual Beam design and assessment follow the same calculation procedures as existing beam element design.

• Results are automatically generated in tabular format and can be exported as comprehensive reports.

• Section properties, material data, and reinforcement/stiffener inputs defined in the Virtual Beam workflow are fully integrated into the design/assessment
process.

• Design and Assessment are supported only for Virtual Beams generated via the Steel Composite Bridge Wizard.

Design Report – AASHTO LRFD

▪ Design > Composite Design > Perform > Perform Design ▪ Rating > Steel/Composite Bridge> Perform > Perform Assessment

Assessment Report – CS 454



10

CIVIL NX 2025 (v2.2)  Release NoteCIVIL NX 2025

8. Virtual Section for Design

• The new Virtual Section for Design functionality enables engineers to quickly optimize cross-sectional dimensions during the design process.

• After completing the design with an initial section, if the section fails to meet design requirements, users can:

• Use Virtual Section for Design to modify flange or web dimensions.

• Re-run the design checks with the updated dimensions without re-analysis.

• By repeating the design step with revised dimensions, users can rapidly identify a section that satisfies the design criteria.

• The same dialog also allows the user to add longitudinal stiffeners into the section.

• Analysis not updated automatically:

• Changes made in Virtual Section for Design are applied only to the design process.

• To update the structural analysis with the final modified dimensions, users must manually reflect the changes in the analysis model.

• Faster optimization: Quickly iterate on section dimensions without time-consuming re-analysis.

Virtual Section for Design Longitudinal Stiffener

▪ Design > Composite Design > Virtual Section for Design
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9. Bearing Stiffener Check (NR/GN/CIV/025) for Steel Railway Bridges

• CIVIL NX now supports Bearing Stiffener assessment in accordance with NR/GN/CIV/025 within the steel railway bridge Assessment workflow.

• You can define the angle connecting the web and the stiffener, and account for corrosion of both the stiffener and the angle in the checks.

• Actions & Load Effects Considered

• Axial Forces on Bearing Stiffener
• Reaction from the support bearing
• Destabilising influence of the web

• Bending Moment
• Tension-field action moment acting on the bearing stiffener

• Restraining Forces
• FS1: Force due to bow of the compression flange
• FS2: Force due to non-verticality of the web at supports
• FL: Additional force due to cross members in U-frames subjected to vertical loading

• Verification Performed

• Yielding of web plate

• Yielding of stiffener

• Buckling of stiffener

Transverse Stiffener Dialog Bearing Stiffener
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10. Intermediate Stiffener Check (NR/GN/CIV/025) for Steel Railway Bridges

• CIVIL NX now supports Intermediate Stiffener assessment in accordance with NR/GN/CIV/025 within the steel railway bridge Assessment workflow.

• You can define the angle connecting the web and the stiffener, and account for corrosion of both the stiffener and the angle in the checks.

• Actions & Load Effects Considered

• Axial Forces on Bearing Stiffener
• Tension-field action
• Destabilising influence of the web

• Restraining Forces on U-frame stiffeners
• FR: Elements providing discrete intermediate restraints
• FC: U-frames with cross members subjected to vertical loading

• Verification Performed

• Yielding of web plate

• Yielding of stiffener

• Buckling of stiffener

Transverse Stiffener Dialog Intermediate Stiffener
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Global Displacements
Local Displacement Table

• In previous versions, displacements under Moving Load could only be displayed with respect to the global coordinate system.

• Starting from this release, CIVIL NX additionally provides displacement results in the local coordinate system.

• Local displacement results are supported for all moving load standards.

• The feature is not available in Moving Load Tracer.

• Local displacements can be checked in the bearing movement direction, enabling more accurate evaluation of curved bridge behavior.

• Local displacements are provided only for nodes with a defined Node Local Axis.

▪ Results > Result Display > Deformations > Displacement Contour ▪ Results > Result Tables > Displacements

11. Local Coordinate Displacement Output under Moving Load Cases

Local Displacements
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